Back to overview
Downtime
Google and AI Mode are down
Feb 16 at 02:14am UTC
Affected services
Backend
Resolved
Feb 16 at 06:31am UTC
Both are back up.
Affected services
Created
Feb 16 at 02:14am UTC
We’re investigating
Affected services