Back to overview
Downtime
Grok website is down
Apr 15, 2026 at 6:10am UTC
Affected services
Grok
Resolved
Apr 15, 2026 at 9:34am UTC
Grok's performance is back to normal.
Affected services
Created
Apr 15, 2026 at 6:10am UTC
grok.com is suffering high demand, thus it can't be accessed.
Affected services