Back to overview
Degraded

Gemini is degraded

May 5, 2026 at 2:00pm UTC
Affected services
Gemini

Resolved
May 5, 2026 at 9:31pm UTC

Gemini is back to normal.

Created
May 5, 2026 at 2:00pm UTC

We are working as fast as we can to solve it.